Skip to main content
VulnerabilityPublished

CVE-2026-115355: Mistune · Path Traversal and XSS in Include directive

Affects jiratuiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-115355· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 1.10.1 soon.

Data as of 30 Oct 2026, 08:45 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 1.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade jiratui to 1.10.1.

Affected software

ProductAffectedFixed in
Homebrewjiratuipkg:brew/jiratuiOther threatsAffected
  • >=1.8.0 <1.10.1
Fixed in
  • 1.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Mistune version 1.10.1 that fixes the path traversal and XSS issues. Users should upgrade to version 1.10.1 or later. Since the Include plugin must be explicitly enabled, disabling or not enabling this plugin can also mitigate exposure. No other specific mitigations are indicated.

Description

CVE-2026-115355 is a vulnerability in the Mistune Markdown parser's Include directive that allows path traversal and cross-site scripting (XSS). The directive does not properly validate file paths, enabling attackers to read arbitrary files via '../' sequences. Additionally, error messages and included file contents are rendered without HTML escaping, causing XSS even when escaping is enabled. This vulnerability affects Mistune versions from 1.8.0 up to but not including 1.10.1. The Include plugin must be explicitly enabled for the vulnerability to be exploitable. A fix is available in version 1.10.1.

References

Community reviews

Loading reviews…