Skip to main content
VulnerabilityPublished Updated

CVE-2026-69097: GitPython · git-config section-name injection enables arbitrary config directives (core.sshCommand RCE)

Affects legitSource GCVE Database

0
Authoritative record:CVE-2026-69097· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 1.2.0.post0_11 soon.

Data as of 26 Oct 2026, 19:13 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.0.post0_11
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade legit to 1.2.0.post0_11.

Affected software

ProductAffectedFixed in
Homebrewlegitpkg:brew/legitOther threatsAffected
  • >=0.1.0 <1.2.0.post0_11
Fixed in
  • 1.2.0.post0_11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 1.2.0.post0_11 that fixes this vulnerability. Users should upgrade to this version or later to mitigate the risk. No additional mitigation steps are required beyond applying the official fix.

Description

GitPython versions up to 3.1.52 contain a vulnerability where attacker-controlled submodule names can inject arbitrary configuration directives into the .git/config file. This occurs because section names are insufficiently sanitized, allowing injection of directives like core.sshCommand, which can lead to remote code execution on the victim's next git operation. The vulnerability is fixed in version 1.2.0.post0_11.

References

Community reviews

Loading reviews…