Skip to main content
CVE-2026-73623VulnerabilityPublished Updated

mistral-vibe · GitPython: Incomplete unsafe_git_clone_options denylist omits --template enabling arbitrary command execution via

Affects mistral-vibeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-73623· High 7.7

Not known to be exploited · CVSS 7.7 High : upgrade to 2.24.0 soon.

Data as of 30 Oct 2026, 07:45 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.24.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mistral-vibe to 2.24.0.

Affected software

ProductAffectedFixed in
Homebrewmistral-vibepkg:brew/mistral-vibeOther threatsAffected
  • >=2.1.0 <2.24.0
Fixed in
  • 2.24.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 2.24.0 that adds --template to the unsafe_git_clone_options denylist, preventing this attack vector. Users should upgrade to version 2.24.0 or later to mitigate this vulnerability. No additional mitigations are required if the patch is applied.

Description

GitPython versions up to 3.1.53 have an incomplete denylist for unsafe git clone options that omits the --template option. This omission allows an attacker who can influence clone options and stage a malicious post-checkout hook in a directory to achieve arbitrary command execution during a git clone operation. The vulnerability requires the attacker to have write access to a directory used as a template containing executable hooks. A fix is available in version 2.24.0.

References

Community reviews

Loading reviews…