Skip to main content
CVE-2026-78679VulnerabilityPublished Updated

nbdime · GitPython: TagReference.create positional reference bypasses kwargs-only --file guard, enabling arbitrary file read

Affects nbdimeSource GCVE Database

0
Authoritative record:CVE-2026-78679· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 4.0.4_8 soon.

Data as of 26 Oct 2026, 17:28 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.4_8
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nbdime to 4.0.4_8.

Affected software

ProductAffectedFixed in
Homebrewnbdimepkg:brew/nbdimeOther threatsAffected
  • >=1.1.0 <4.0.4_8
Fixed in
  • 4.0.4_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 4.0.4_8 that properly includes positional arguments in the unsafe option checks or places a '--' separator before positional arguments to prevent option injection. Users should upgrade to version 4.0.4_8 or later to remediate this vulnerability. Until patched, avoid passing user-controlled values as positional 'reference' arguments to TagReference.create().

Description

GitPython versions up to 3.1.58 contain a vulnerability in the TagReference.create() method where a positional 'reference' argument can bypass the unsafe option guard for '--file', allowing an attacker to read arbitrary local files. This occurs because the guard only inspects keyword arguments, not positional ones, enabling an attacker to supply '--file=<path>' as a positional reference. The file contents are returned in the annotated tag message. A fix is available in version 4.0.4_8.

References

Community reviews

Loading reviews…