Repo.init enables arbitrary command execution · GitPython: Unguarded git option forwarding
Affects cruftSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 2.16.0_14 soon.
Data as of 26 Oct 2026, 17:42 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.16.0_14
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade cruft to 2.16.0_14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewcruftpkg:brew/cruftOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in GitPython version 2.16.0_14 that adds checks to prevent unsafe options like --template and --separate-git-dir from being used in Repo.init. Users should upgrade to this fixed version or later. Until patched, avoid passing untrusted or attacker-controlled values to the template parameter of Repo.init. No other mitigations are specified.
Description
GitPython's Repo.init method forwards keyword arguments directly to git init without checking for unsafe options. This allows an attacker who can control the template parameter to plant malicious git hooks that execute arbitrary code during subsequent git operations. The vulnerability affects GitPython versions up to 3.1.57 and requires the attacker to stage an executable hook directory at a known path. A fix is available in version 2.16.0_14 that adds unsafe option checks.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-9rj7-rf2p-w77r (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-76218 (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2204 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/d9ddb55bdc66 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.58 (opens in a new tab)
- vulncheck.com/advisories/gitpython-before-remote-code-execution-via-repo-init (opens in a new tab)