IndexFile.from_tree/reset/merge_tree enables arbitrary file · GitPython: Unguarded git read-tree option forwarding
Affects nbdimeSource GCVE Database
Not known to be exploited · CVSS 7.2 High : upgrade to 4.0.4_7 soon.
Data as of 26 Oct 2026, 17:29 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.4_7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nbdime to 4.0.4_7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewnbdimepkg:brew/nbdimeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in GitPython version 4.0.4_7. Users should upgrade to this version or later. The fix involves adding a 'check_unsafe_options' guard with an 'allow_unsafe_options' parameter to the affected methods and/or placing a '--' separator before positional treeish arguments to block injection of '--index-output'. Until upgraded, avoid passing untrusted input to these methods.
Description
GitPython versions up to 3.1.57 contain a vulnerability in the IndexFile.from_tree, reset, and merge_tree methods where unguarded forwarding of positional treeish arguments to 'git read-tree' allows an attacker to inject the '--index-output' option. This leads to arbitrary file overwrite with a valid git-index blob at the privileges of the host process. The vulnerability does not allow arbitrary code execution but can corrupt or destroy files at attacker-controlled writable paths. A fix is available in version 4.0.4_7.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-4gmw-gg2m-w46p (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-76219 (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2204 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/9b5dcaf85da5946dbf69dcd53f9edba08f760b32 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.58 (opens in a new tab)
- vulncheck.com/advisories/gitpython-before-arbitrary-file-overwrite-via-read-tree (opens in a new tab)