CVE-2026-42284: GitPython · Unsafe option check validates multi_options before shlex.split transformation
Affects cruftSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 2.16.0_8 soon.
Data as of 26 Oct 2026, 17:42 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.16.0_8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade cruft to 2.16.0_8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewcruftpkg:brew/cruftOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in GitPython version 2.16.0_8 that fixes this vulnerability. Users should upgrade to version 2.16.0_8 or later to mitigate the risk. Until upgraded, avoid passing untrusted input to the multi_options parameter in clone or submodule update operations.
Description
GitPython versions from 2.9.0 up to but not including 2.16.0_8 contain a vulnerability in the handling of multi_options in clone operations. The validation of unsafe options is performed on the original list of options before they are transformed by shlex.split, allowing crafted input to bypass checks and inject unsafe Git configuration options that execute attacker-controlled hooks during cloning or submodule updates.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-x2qx-6953-8485 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-42284 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.47 (opens in a new tab)
- tenable.com/cve/CVE-2026-32686 (opens in a new tab)