Skip to main content
VulnerabilityPublished Updated

CVE-2026-42284: GitPython · Unsafe option check validates multi_options before shlex.split transformation

Affects legitSource GCVE Database

0
Authoritative record:CVE-2026-42284· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 1.2.0.post0_9 soon.

Data as of 26 Oct 2026, 19:12 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.0.post0_9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade legit to 1.2.0.post0_9.

Affected software

ProductAffectedFixed in
Homebrewlegitpkg:brew/legitOther threatsAffected
  • >=0.1.0 <1.2.0.post0_9
Fixed in
  • 1.2.0.post0_9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 1.2.0.post0_9 that fixes the unsafe option validation logic. Users and applications should upgrade to this version or later to mitigate the vulnerability. No other mitigation is indicated by the vendor advisory.

Description

GitPython versions from 0.1.0 up to but not including 1.2.0.post0_9 contain a vulnerability in the handling of multi_options in clone operations. The validation of unsafe options is performed on the original list of options before they are transformed by shlex.split, allowing an attacker to embed unsafe options like '--config core.hooksPath=...' within a single string that bypasses the check. This leads to execution of attacker-controlled Git hooks during cloning or submodule updates.

References

Community reviews

Loading reviews…