CVE-2026-42284: GitPython · Unsafe option check validates multi_options before shlex.split transformation
Affects nbdimeSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 4.0.4_2 soon.
Data as of 26 Oct 2026, 17:27 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.4_2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nbdime to 4.0.4_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewnbdimepkg:brew/nbdimeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in GitPython version 4.0.4_2 that fixes this issue. Users should upgrade to version 4.0.4_2 or later to remediate this vulnerability. Until patched, avoid passing untrusted input to multi_options parameters in clone or submodule update operations.
Description
GitPython versions >=1.1.0 and <4.0.4_2 contain a vulnerability in the handling of multi_options in clone operations. The code validates the original multi_options list but executes a transformed version after splitting, allowing an attacker to embed unsafe options like '--config core.hooksPath' that bypass validation. This can lead to execution of attacker-controlled Git hooks during cloning or submodule updates.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-x2qx-6953-8485 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-42284 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.47 (opens in a new tab)
- tenable.com/cve/CVE-2026-32686 (opens in a new tab)