Skip to main content
VulnerabilityPublished

CVE-2026-119196: Glances · pyasn1 has quadratic CPU consumption in constructed BIT STRING decoding

Affects glancesSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-119196· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.3.3_1 or 3.1.6.2 soon.

Data as of 31 Oct 2026, 16:08 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 4.3.3_1, 3.1.6.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade glances to 4.3.3_1 or 3.1.6.2.

Affected software

ProductAffectedFixed in
Homebrewglancespkg:brew/glancesOther threatsAffected
  • >=3.0.2_1 <3.1.6.2
  • >=4.3.1_1 <4.3.3_1
  • >=4.5.0.1
Fixed in
  • 3.1.6.2
  • 4.3.3_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and fixed versions include 3.1.6.2 and 4.3.3_1. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation is required if the application uses these fixed versions.

Description

CVE-2026-119196 is a high-severity vulnerability in the pyasn1 library used by Glances, where decoding constructed BIT STRING values with many fragments causes quadratic CPU consumption. This can lead to CPU exhaustion and denial of service when processing attacker-controlled ASN.1 data. The issue affects BER and CER decoders and certain schema-driven DER decoding paths. The vulnerability is fixed in pyasn1 versions 3.1.6.2 and 4.3.3_1.

References

Community reviews

Loading reviews…