Skip to main content
VulnerabilityPublished

CVE-2026-119197: Glances · pyasn1 has quadratic-complexity denial of service in binary REAL decoding

Affects glancesSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119197· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.3.3_1 or 3.1.6.2 soon.

Data as of 31 Oct 2026, 16:08 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 4.3.3_1, 3.1.6.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade glances to 4.3.3_1 or 3.1.6.2.

Affected software

ProductAffectedFixed in
Homebrewglancespkg:brew/glancesOther threatsAffected
  • >=3.0.2_1 <3.1.6.2
  • >=4.3.1_1 <4.3.3_1
  • >=4.5.0.1
Fixed in
  • 3.1.6.2
  • 4.3.3_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in pyasn1 version 0.6.5, which replaces the inefficient decoding loop with a more efficient implementation. Users should upgrade to pyasn1 0.6.5 or later to remediate this issue. Until upgrading, applications should reject or strictly limit ASN.1 input containing REAL values, especially large mantissas, before passing it to pyasn1 decoders. The appropriate input size limit depends on the application's CPU resources and expected request volume.

Description

CVE-2026-119197 is a denial of service vulnerability in pyasn1 versions up to 0.6.4 used by Glances. It arises from a quadratic-complexity loop in decoding binary-encoded ASN.1 REAL values with large mantissas, causing excessive CPU consumption. The flaw affects BER, CER, and DER decoders. An attacker supplying crafted ASN.1 REAL data to an affected decoder can cause CPU exhaustion during decoding. The issue is fixed in pyasn1 0.6.5. Users should upgrade to this version or apply input restrictions to mitigate the risk.

References

Community reviews

Loading reviews…