Skip to main content
VulnerabilityPublished Updated

CVE-2024-52531: GNOME libsoup before 3.6.1 allows a buffer overflow in applications that perform conversion to UTF-8

Affects libsoupSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52531· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.6.1 when convenient.

Data as of 30 Oct 2026, 03:29 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Sources agree

CVSS scores by source
CNA (mitre)CVSS 3.16.5
CISA-ADPCVSS 3.18.4
Affects
GNOME libsoup before 3.6.1
Patch
Available – fixed in 3.6.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Debian debian/libsoup package to 3.6.1.

Affected software

ProductAffectedFixed in
Debiandebian/libsouppkg:deb/debian/libsoupOther threatsAffected
  • <3.6.1
Fixed in
  • 3.6.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GNOME libsoup version 3.6.1. Users and administrators should upgrade to version 3.6.1 or later to remediate this vulnerability. No additional mitigation steps are indicated since network input cannot trigger the issue.

Description

A buffer overflow vulnerability exists in GNOME libsoup versions before 3.6.1 in the function soup_header_parse_param_list_strict when performing conversion to UTF-8. This flaw cannot be triggered by input received over the network.

References

Community reviews

Loading reviews…