Skip to main content
CVE-2024-52531VulnerabilityPublished Updated

CVE-2024-52531: GNOME libsoup · Out-of-bounds Write

Affects GNOME libsoupSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.6.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.6.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade debian/libsoup to 3.6.1.

Affected software

ProductAffectedFixed in
Debiandebian/libsouppkg:deb/debian/libsoupOther threatsAffected
  • <3.6.1
Fixed in
  • 3.6.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should take the following specific steps: 1) Identify all systems and applications using libsoup versions prior to 3.6.1, including embedded devices and desktop environments. 2) Monitor GNOME and Linux distribution security advisories for official patches or updates addressing CVE-2024-52531 and apply them promptly. 3) If patches are not yet available, consider applying temporary mitigations such as restricting or filtering HTTP traffic to vulnerable applications, especially from untrusted networks. 4) Employ network intrusion detection systems (NIDS) with updated signatures to detect anomalous HTTP header patterns that could indicate exploitation attempts. 5) Conduct code audits or penetration tests on custom applications using libsoup to assess exposure. 6) Educate system administrators about the vulnerability and ensure incident response plans include this threat. 7) Where feasible, isolate vulnerable services behind firewalls or proxy servers that can sanitize HTTP headers. 8) Maintain up-to-date backups and system monitoring to quickly recover from potential exploitation. These targeted actions go beyond generic advice by focusing on the specific vulnerable function and attack vector.

Description

GNOME libsoup before 3.6.1 allows a buffer overflow in applications that perform conversion to UTF-8 in soup_header_parse_param_list_strict. There is a plausible way to reach this remotely via soup_message_headers_get_content_type (e.g., an application may want to retrieve the content type of a request or response).

References

Community reviews

Loading reviews…