Skip to main content
VulnerabilityPublished Updated

CVE-2024-52532: GNOME libsoup before 3.6.1 has an infinite loop, and memory consumption

Affects libsoupSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52532· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 3.6.1 soon.

Data as of 29 Oct 2026, 23:00 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Affects
GNOME libsoup before 3.6.1
Patch
Available – fixed in 3.6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Debian debian/libsoup package to 3.6.1.

Affected software

ProductAffectedFixed in
Debiandebian/libsouppkg:deb/debian/libsoupOther threatsAffected
  • <3.6.1
Fixed in
  • 3.6.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to GNOME libsoup version 3.6.1 or later, where this issue is fixed.

Description

A vulnerability in GNOME libsoup before version 3.6.1 causes an infinite loop and excessive memory consumption when processing certain WebSocket data patterns from clients. This can lead to denial of service due to resource exhaustion.

References

Community reviews

Loading reviews…