Skip to main content
VulnerabilityPublished Updated

CVE-2026-7737: github.com/osrg/gobgp · GoBGP has Improper Restriction of Operations within the Bounds of a Memory Buffer

Affects github.com/osrg/gobgpSource GCVE Database

0
Authoritative record:CVE-2026-7737· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.4.0 when convenient.

Data as of 27 Oct 2026, 00:43 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade github.com/osrg/gobgp to 4.4.0.

Affected software

ProductAffectedFixed in
Gogithub.com/osrg/gobgpAffected
  • <4.4.0
Fixed in
  • 4.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GoBGP to version 4.4.0 or later, where this vulnerability is fixed. The patch is identified by commit bc77597d42335c78464bc8e15a471d887bbdf260. No other mitigations are specified or required.

Description

GoBGP versions prior to 4.4.0 contain a vulnerability in the BMP Parser component where improper restriction of operations within memory buffer bounds leads to an out-of-bounds read. This flaw affects the BMPPeerUpNotification.ParseBody and BMPStatisticsReport.ParseBody functions in the pkg/packet/bmp/bmp.go file. The vulnerability can be exploited remotely and may cause a denial of service due to application instability. Upgrading to version 4.4.0 resolves the issue.

References

Community reviews

Loading reviews…