Skip to main content
CVE-2026-88922VulnerabilityPublished Updated

Golang github hashicorp go getter: The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege

Affects golang-github-hashicorp-go-getterSource GCVE Database

0
Authoritative record:CVE-2026-88922· Medium 6.7

Not known to be exploited · CVSS 6.7 Medium · fixed in 1.8.9 : update golang-github-hashicorp-go-getter when convenient.

Data as of 29 Oct 2026, 01:28 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.9
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSgolang-github-hashicorp-go-getterpkg:deb/ubuntu/golang-github-hashicorp-go-getter?arch=source&distro=nobleOther threatsAffected
  • =1.4.1-1
Fixed in–
Ubuntu 22.04 LTSgolang-github-hashicorp-go-getterpkg:deb/ubuntu/golang-github-hashicorp-go-getter?arch=source&distro=jammyOther threatsAffected
  • =1.4.1-1
Fixed in–
Ubuntu 20.04 LTSgolang-github-hashicorp-go-getterpkg:deb/ubuntu/golang-github-hashicorp-go-getter?arch=source&distro=focalOther threatsAffected
  • =0.0~git20160316.0.575ec4e-1
  • =1.4.0-1
  • =1.4.1-1
Fixed in–
Ubuntu 18.04 LTSgolang-github-hashicorp-go-getterpkg:deb/ubuntu/golang-github-hashicorp-go-getter?arch=source&distro=bionicOther threatsAffected
  • =0.0~git20160316.0.575ec4e-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the go-getter library to version 1.8.9 or later, or 2.2.4 or later, where this vulnerability is fixed. No other mitigation is indicated.

Description

The go-getter library up to versions 1.8.8 and 2.2.3 contains a privilege escalation vulnerability in its archive decompression handling. A crafted archive may cause files to be extracted with elevated permission bits. If extraction is performed by a privileged user, a local attacker could gain the privileges of that user. This issue is fixed in versions 1.8.9 and 2.2.4.

References

Community reviews

Loading reviews…