CVE-2026-77405: Golang github rabbitmq amqp091 go: RabbitMQ amqp091-go is a Go AMQP 0.9.1 client
Affects golang-github-rabbitmq-amqp091-goSource GCVE Database
Not known to be exploited · CVSS 9.4 Critical · fixed in 1.13.0 : patch golang-github-rabbitmq-amqp091-go as a priority.
Data as of 29 Oct 2026, 01:43 UTC
- Patch
- Available – fixed in 1.13.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10golang-github-rabbitmq-amqp091-gopkg:deb/ubuntu/golang-github-rabbitmq-amqp091-go?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSgolang-github-rabbitmq-amqp091-gopkg:deb/ubuntu/golang-github-rabbitmq-amqp091-go?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSgolang-github-rabbitmq-amqp091-gopkg:deb/ubuntu/golang-github-rabbitmq-amqp091-go?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to amqp091-go version 1.13.0 or later, where the tlsConfigFromURI function sets MinVersion to tls.VersionTLS12, preventing negotiation of obsolete TLS versions. No other mitigation is required if the upgrade is applied.
Description
RabbitMQ amqp091-go versions prior to 1.13.0 do not set the minimum TLS version to TLS 1.2 in their TLS configuration. This allows clients built with Go runtimes that permit TLS 1.0 or 1.1 by default to negotiate outdated and less secure TLS versions when connecting via amqps URIs. The issue is fixed in version 1.13.0.
References
- ubuntu.com/security/CVE-2026-77405 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-77405 (opens in a new tab)
- github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h (opens in a new tab)
- github.com/rabbitmq/amqp091-go/pull/355 (opens in a new tab)
- github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e (opens in a new tab)