CVE-2026-33236: Gptline · NLTK has a Downloader Path Traversal Vulnerability (AFO) - Arbitrary File Overwrite
Affects gptlineSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 1.0.8_16 soon.
Data as of 5 Nov 2026, 05:58 UTC
- Patch
- Available – fixed in 1.0.8_16
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade gptline to 1.0.8_16.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewgptlinepkg:brew/gptlineOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in NLTK version 1.0.8_16 that addresses this vulnerability. Users should upgrade to version 1.0.8_16 or later to remediate the issue. Until patched, avoid using untrusted or attacker-controlled XML index servers with the NLTK downloader. No vendor advisory indicates that no action is required or that the issue is already mitigated without patching.
Description
NLTK's downloader component contains a path traversal vulnerability in its handling of remote XML index files. The vulnerability arises because the downloader does not validate the 'subdir' and 'id' attributes, allowing an attacker controlling a remote XML index server to specify path traversal sequences. This can lead to arbitrary directory creation and arbitrary file overwrite on the victim's file system, including critical system files such as /etc/passwd. The vulnerability is identified as CVE-2026-33236 and has a high severity with a CVSS score of 8.1. A fix is available in version 1.0.8_16.
References
- github.com/nltk/nltk/security/advisories/GHSA-469j-vmhf-r6v7 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-33236 (opens in a new tab)
- github.com/nltk/nltk/commit/89fe2ec2c6bae6e2e7a46dad65cc34231976ed8a (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:10184 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:19712 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37275 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:42644 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-33236 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2449824 (opens in a new tab)
- github.com/nltk/nltk (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/nltk/PYSEC-2026-2237.yaml (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33236.json (opens in a new tab)