Skip to main content
VulnerabilityPublished Updated

CVE-2026-0847: Gptline · NLTK has a Path Traversal issue

Affects gptlineSource GCVE Database

0
Compare
Authoritative record:CVE-2026-0847· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 1.0.8_14 soon.

Data as of 5 Nov 2026, 05:58 UTC

CVSS 3.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.0.8_14
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade gptline to 1.0.8_14.

Affected software

ProductAffectedFixed in
Homebrewgptlinepkg:brew/gptlineOther threatsAffected
  • >=1.0.8 <1.0.8_14
Fixed in
  • 1.0.8_14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 1.0.8_14. Users should upgrade affected NLTK versions to 1.0.8_14 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

NLTK versions up to and including 3.9.2 contain a path traversal vulnerability in multiple CorpusReader classes, allowing attackers to read arbitrary files on the server. This flaw arises from improper sanitization of file paths in classes such as WordListCorpusReader, TaggedCorpusReader, and BracketParseCorpusReader. Exploitation can lead to unauthorized access to sensitive files, including system files and private keys, and may enable remote code execution when combined with other vulnerabilities. A fix is available in version 1.0.8_14.

References

Community reviews

Loading reviews…