Skip to main content
CVE-2026-75507VulnerabilityPublished Updated

moto · GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule

Affects motoSource GCVE Database

0
Compare
Authoritative record:CVE-2026-75507· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.2.3_1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.2.3_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade moto to 5.2.3_1.

Affected software

ProductAffectedFixed in
Homebrewmotopkg:brew/motoOther threatsAffected
  • >=2.3.2 <5.2.3_1
Fixed in
  • 5.2.3_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GraphQL-core to version 5.2.3_1 or later, where the vulnerability is fixed by enforcing a maximum field comparison budget during validation. If upgrading is not immediately possible, implement request body-size limits on the decompressed request to reject oversized documents before validation. Removing the OverlappingFieldsCanBeMerged rule is not recommended as it is required for specification compliance. The fix causes pathological queries to fail validation quickly rather than consuming excessive CPU.

Description

A denial of service vulnerability exists in GraphQL-core's OverlappingFieldsCanBeMerged validation rule due to quadratic complexity in processing certain queries. A crafted query can cause excessive CPU consumption during validation, potentially exhausting server resources for minutes. This affects all GraphQL-core based servers with default settings. The issue is fixed in versions 5.2.3_1 and later.

References

Community reviews

Loading reviews…