Skip to main content
VulnerabilityPublished Updated

CVE-2026-52720: Gst plugins bad1.0 · A heap buffer overflow vulnerability was found in GStreamer's librfb (RFB/VNC client)

Affects gst-plugins-bad1.0Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-52720· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 8.10 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Red Hat redhat/gstreamer1-plugins-bad-free package to 8.10.

Affected software

ProductAffectedFixed in
Red Hatredhat/gstreamer1-plugins-bad-freepkg:rpm/redhat/gstreamer1-plugins-bad-freeOther threatsAffected
  • >=8.0.0 <8.10
Fixed in
  • 8.10
Ubuntu Pro 14.04 LTSgst-plugins-bad1.0pkg:deb/ubuntu/gst-plugins-bad1.0?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 1.2.0-3ubuntu5 – 1.2.4-1~ubuntu1.1+esm1
11 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSgst-plugins-bad1.0pkg:deb/ubuntu/gst-plugins-bad1.0?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • 1.6.0-1ubuntu1 – 1.8.3-1ubuntu0.2+esm2
16 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSgst-plugins-bad1.0pkg:deb/ubuntu/gst-plugins-bad1.0?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 1.12.3-1ubuntu1 – 1.14.5-0ubuntu1~18.04.1+esm2
13 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSgst-plugins-bad1.0pkg:deb/ubuntu/gst-plugins-bad1.0?arch=source&distro=esm-apps/focalOther threatsAffected
  • 1.16.1-1ubuntu1 – 1.16.3-0ubuntu1.1+esm2
14 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSgst-plugins-bad1.0pkg:deb/ubuntu/gst-plugins-bad1.0?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 1.18.5-1ubuntu1 – 1.20.3-0ubuntu1.1+esm3
8 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has issued an official security update (RHSA-2026:37130) for the gstreamer1-plugins-bad-free package in Red Hat Enterprise Linux 8 that addresses this vulnerability. Users should apply the update as described in the Red Hat advisory and associated article (https://access.redhat.com/articles/11258) to remediate the issue. No alternative mitigations or workarounds are specified in the advisory. Patch status: official fix available.

Description

GStreamer is a streaming media framework based on graphs of filters which operate on media data. The gstreamer1-plugins-bad-free package contains a collection of plug-ins for GStreamer. Security Fix(es): * gstreamer1-plugins-bad-free: GStreamer: Heap buffer overflow via crafted VNC server rectangle in librfb (CVE-2026-52720) * gstreamer1-plugins-bad-free: GStreamer: Signed integer overflow in VMnc decoder cursor payload handling (CVE-2026-52722) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…