Skip to main content
VulnerabilityPublished

CVE-2026-110353: haproxy vulnerabilities

Affects haproxySource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-110353· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 2.4.30-0ubuntu0.22.04.3 : patch haproxy soon.

Data as of 4 Nov 2026, 04:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.17.5
Patch
Available – fixed in 2.4.30-0ubuntu0.22.04.3, 2.8.30-0ubuntu0.24.04.2, 3.4.2-1ubuntu4.1 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10haproxypkg:deb/ubuntu/haproxy?arch=source&distro=stonkingOther threatsAffected
  • <3.4.2-1ubuntu4.1
Fixed in
  • 3.4.2-1ubuntu4.1
Ubuntu 26.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=resoluteOther threatsAffected
  • <3.2.25-0ubuntu0.26.04.2
Fixed in
  • 3.2.25-0ubuntu0.26.04.2
Ubuntu 24.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=nobleOther threatsAffected
  • <2.8.30-0ubuntu0.24.04.2
Fixed in
  • 2.8.30-0ubuntu0.24.04.2
Ubuntu 22.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=jammyOther threatsAffected
  • <2.4.30-0ubuntu0.22.04.3
Fixed in
  • 2.4.30-0ubuntu0.22.04.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerabilities have been fixed in updated HAProxy package versions for Ubuntu. Users should apply the official patches by upgrading to the following versions or later: 2.4.30-0ubuntu0.22.04.3 for Ubuntu 22.04 LTS, 2.8.30-0ubuntu0.24.04.2 for Ubuntu 24.04 LTS, 3.2.25-0ubuntu0.26.04.2 for Ubuntu 26.04 LTS, and 3.4.2-1ubuntu4.1 for Ubuntu 26.10. A standard system update will apply these fixes. No additional mitigation steps are required beyond applying these updates.

Description

Two vulnerabilities in HAProxy were discovered involving improper handling of truncated HTTP/2 PING frames and certain HTTP/1.1 chunked requests. These issues could allow a remote attacker to cause HAProxy to consume excessive CPU resources, resulting in denial of service conditions. The vulnerabilities affect multiple Ubuntu package versions and have been addressed in updated package releases.

References

Community reviews

Loading reviews…