Skip to main content
CVE-2026-105626VulnerabilityPublished Updated

HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an

Affects consulSource GCVE Database

0
Authoritative record:CVE-2026-105626· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 2.1.0 : patch consul soon.

Data as of 29 Oct 2026, 00:27 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTSconsulpkg:deb/ubuntu/consul?arch=source&distro=jammyOther threatsAffected
  • =1.7.4+dfsg1-1
  • =1.8.7+dfsg1-3
Fixed in–
Ubuntu 20.04 LTSconsulpkg:deb/ubuntu/consul?arch=source&distro=focalOther threatsAffected
  • 1.0.7~dfsg1-5ubuntu1 – 1.5.2+dfsg2-14
6 affected builds
Fixed in–
Ubuntu 18.04 LTSconsulpkg:deb/ubuntu/consul?arch=source&distro=bionicOther threatsAffected
  • =0.6.4~dfsg-3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should upgrade to Consul Community Edition 2.1.0 or Consul Enterprise 2.1.0 or 1.21.19 to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

HashiCorp Consul and Consul Enterprise contain a denial of service vulnerability in the HTTP API that allows unauthenticated attackers to exhaust memory on a Consul agent. This vulnerability is identified as CVE-2026-105626 and has a high severity rating. It affects specific versions of Consul prior to 2.1.0. The issue is resolved in Consul Community Edition 2.1.0 and Consul Enterprise versions 2.1.0 and 1.21.19.

References

Community reviews

Loading reviews…