hickory-dns from 0.20.1 before 0.26.2 contains a denial of service vulnerability in the hickory-proto SVCB and HTTPS
Source GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 0.26.2 soon.
Data as of 8 Nov 2026, 06:33 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.5 |
- Patch
- Available – fixed in 0.26.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade hickory-dns to 0.26.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| hickory-dnshickory-dns | Affected
| Fixed in
|
crates.iohickory-dnspkg:cargo/hickory-dnsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 0.26.2 or later addresses this vulnerability. Users should upgrade to version 0.26.2 or later to remediate this issue. No other mitigations or workarounds are indicated.
Description
A denial of service vulnerability exists in hickory-dns versions from 0.20.1 up to but not including 0.26.2. The flaw is in the hickory-proto SVCB and HTTPS record parser, where specially crafted zone files with single or double quotes replacing service parameter values cause a panic and crash the parser.