CVE-2026-59939: httplib2 · Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling
Affects prowlerSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 5.31.1_1 soon.
Data as of 31 Oct 2026, 16:35 UTC
- Patch
- Available – fixed in 5.31.1_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade prowler to 5.31.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewprowlerpkg:brew/prowlerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading httplib2 to version 5.31.1_1 or later. This version includes fixes that prevent unbounded decompression. Until patched, avoid making HTTP requests with httplib2 to untrusted or attacker-controlled servers. There is no indication that the vulnerability is mitigated by configuration or other means.
Description
The httplib2 HTTP client library has a vulnerability in its handling of gzip and deflate compressed HTTP response bodies. It performs unbounded decompression without limits on the decompressed size, allowing a malicious server to send a small compressed payload that expands to a very large size in memory. This can cause the client process to run out of memory or crash due to MemoryError. The vulnerability affects any application using httplib2.Http().request() with untrusted HTTP endpoints. A fix is available in version 5.31.1_1.
References
- github.com/httplib2/httplib2/security/advisories/GHSA-j5g9-f88f-gfj3 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59939 (opens in a new tab)
- github.com/httplib2/httplib2/commit/87581ad6cf752fe3da2090c59058261d2d00a427 (opens in a new tab)
- github.com/httplib2/httplib2 (opens in a new tab)
- github.com/httplib2/httplib2/releases/tag/v0.32.0 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/httplib2/PYSEC-2026-3444.yaml (opens in a new tab)
- lists.debian.org/debian-lts-announce/2026/08/msg00039.html (opens in a new tab)