CVE-2026-59884: Prowler · pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs
Affects prowlerSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 5.31.1_1 soon.
Data as of 31 Oct 2026, 16:35 UTC
- Patch
- Available – fixed in 5.31.1_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade prowler to 5.31.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewprowlerpkg:brew/prowlerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in pyasn1 version 5.31.1_1 that limits long-form tag IDs to 20 octets and improves error handling. Users should upgrade to this fixed version. As a workaround, applications can bound the size of untrusted input passed to the decode() function to prevent excessive resource consumption.
Description
CVE-2026-59884 is a denial of service vulnerability in the pyasn1 library's BER/CER/DER decoders. The flaw allows crafted inputs with unbounded long-form tag IDs to cause excessive CPU consumption due to quadratic growth in processing time. On Python 3.11 and later, it can also trigger unhandled ValueErrors during error message formatting, potentially bypassing error handling. The issue affects decoding of untrusted BER/CER/DER inputs in pyasn1 versions from 3.4.0 up to but not including 5.31.1_1. The vulnerability is fixed in version 5.31.1_1 by limiting tag ID size and improving error handling.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-m4p7-r5rc-7g4j (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59884 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/628e36ecbb5277a3f01572ce418ef54271b165a5 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.4 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/pyasn1/PYSEC-2026-3455.yaml (opens in a new tab)