Skip to main content
VulnerabilityPublished

github.com/apernet/hysteria · Hysteria vulnerable to server crash when max_datagram_frame_size very small

Affects github.com/apernet/hysteriaSource GCVE Database

0

CVSS 7.5 High : upgrade to 2.9.2 soon.

Data as of 26 Jun 2026, 22:09 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.9.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

What to do

Upgrade github.com/apernet/hysteria to 2.9.2.

Affected software

ProductAffectedFixed in
Gogithub.com/apernet/hysteriaAffected
  • <2.9.2
Fixed in
  • 2.9.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid accepting clients that advertise very small max_datagram_frame_size values.

Description

An authenticated client can crash the Hysteria server by advertising a very small QUIC max_datagram_frame_size and triggering a UDP response. The server's fragmentation code does not handle cases where the UDP message header size exceeds the maximum datagram payload size, causing a slice bounds panic and server termination. This vulnerability affects Hysteria versions prior to 2.9.2.

References

Community reviews

Loading reviews…