Skip to main content
VulnerabilityPublished

Icu minify: mcp-data-vis vulnerable to denial of service via unsanitized `select` key lookup on `Object.prototype`

Affects icu-minifySource GCVE Database

0

CVSS 3.7 Low : upgrade to 4.9.2 when convenient.

Data as of 27 Oct 2026, 02:11 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.9.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

What to do

Upgrade icu-minify to 4.9.2.

Affected software

ProductAffectedFixed in
npmicu-minifyAffected
  • <4.9.2
Fixed in
  • 4.9.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in icu-minify version 4.9.2 that addresses this issue. Users should upgrade to version 4.9.2 or later to remediate the vulnerability. No other mitigation or workaround is indicated by the vendor advisory.

Description

The icu-minify library has a vulnerability in its runtime formatter for 'select' branches where user input is used as a key to look up options on a plain object that inherits from Object.prototype. If the input coerces to a key present on Object.prototype (e.g., toString, __proto__, constructor), the lookup returns a function instead of the expected fallback option, causing a TypeError and crashing the formatter. This can lead to denial of service in applications using icu-minify, such as Next.js SSR with next-intl's experimental precompilation feature, resulting in HTTP 500 errors on affected renders. The issue is fixed in version 4.9.2.

References

Community reviews

Loading reviews…