ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a heap-based buffer overflow in the X11 animate
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium · fixed in 6.9.13 : update imagemagick when convenient.
Data as of 28 Oct 2026, 22:44 UTC
- Patch
- Available – fixed in 6.9.13
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in ImageMagick versions 6.9.13-58 and 7.1.2-33 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No additional mitigation steps are indicated.
Description
ImageMagick versions before 6.9.13-58 and 7.x before 7.1.2-33 contain a heap-based buffer overflow vulnerability in the X11 animate operation. This flaw allows an attacker to supply a crafted image that, when processed with the X11 animate operation, can overwrite heap memory and crash the application. The vulnerability has a low severity score and does not impact confidentiality or integrity but can cause denial of service through application crashes.
References
- ubuntu.com/security/CVE-2026-116160 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-116160 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-6p6q-wfrv-ffhh (opens in a new tab)
- vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-heap-buffer-overflow-via-x11-animate (opens in a new tab)