CVE-2026-116156: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a memory leak caused by a missing
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium.
Data as of 28 Oct 2026, 22:44 UTC
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ImageMagick to version 6.9.13-58 or later, or 7.1.2-33 or later, where this memory leak has been fixed. Avoid processing untrusted images with the -set profile option until patched.
Description
ImageMagick versions before 6.9.13-58 and 7.x before 7.1.2-33 contain a memory leak vulnerability triggered by the use of the -set profile option. This flaw can cause memory exhaustion and potentially lead to denial of service if an attacker convinces a user to process crafted images using this option. The vulnerability has a low severity rating with a CVSS score of 3.3.
References
- ubuntu.com/security/CVE-2026-116156 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-116156 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-7r5g-p7ff-jgcp (opens in a new tab)
- vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-memory-leak-via-set-profile-option (opens in a new tab)