CVE-2026-119123: ImageMagick before 7.1.2-34 contains a stack overflow vulnerability in the TIFF decoder that occurs
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium · fixed in 7.1.2 : update imagemagick when convenient.
Data as of 4 Nov 2026, 05:00 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.7 |
- Patch
- Available – fixed in 7.1.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in ImageMagick version 7.1.2-34 and later. Users should upgrade to this version or later to remediate the vulnerability. No additional mitigation steps are indicated.
Description
ImageMagick versions before 7.1.2-34 contain a stack overflow vulnerability in the TIFF decoder that can be triggered when the DNG decoder is disabled. An attacker can supply a crafted image file to cause a stack overflow, resulting in application crash and denial of service.
References
- ubuntu.com/security/CVE-2026-119123 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-119123 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-g5j8-ff59-wp88 (opens in a new tab)
- vulncheck.com/advisories/imagemagick-before-7.1.2-34-stack-overflow-in-tiff-decoder (opens in a new tab)