CVE-2026-106580: ImageMagick is free and open-source software used for editing and manipulating digital images
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 8.2 High · fixed in 7.1.2 : patch imagemagick soon.
Data as of 27 Oct 2026, 08:13 UTC
- Patch
- Available – fixed in 7.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ImageMagick to version 7.1.2-31 or later, or 6.9.13-56 or later, where the vulnerability has been fixed. Applying these official fixes is the recommended remediation.
Description
ImageMagick versions prior to 7.1.2-31 and 6.9.13-56 contain a vulnerability in the CUT encoder due to a missing security-policy check. This flaw allows crafted local encoding operations to read data that should be denied by policy and can cause a crash. The issue is fixed in versions 7.1.2-31 and 6.9.13-56.
References
- ubuntu.com/security/CVE-2026-106580 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-106580 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-r868-pmwh-fv2c (opens in a new tab)
- github.com/ImageMagick/ImageMagick/commit/768bdd0dbb9a9ad743b6a6e557126b788b325970 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-31 (opens in a new tab)
- github.com/ImageMagick/ImageMagick6/commit/ad178e41fce2afa6be2b91fb4e7f41c4c5448117 (opens in a new tab)
- github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-56 (opens in a new tab)