imgproxy from 4.0.0 before 4.0.16 contains an integer overflow in the ICO loader that allows remote attackers to
Source GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 4.0.16 as a priority.
Data as of 8 Nov 2026, 06:20 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 9.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 9.8 |
- Patch
- Available – fixed in 4.0.16
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade imgproxy to 4.0.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| imgproxyimgproxy | Affected
| Fixed in
|
Goimgproxypkg:golang/imgproxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in imgproxy version 4.0.16. Users should upgrade to version 4.0.16 or later to remediate this vulnerability. No other mitigation or temporary workaround is indicated.
Description
imgproxy versions from 4.0.0 up to but not including 4.0.16 contain an integer overflow vulnerability in the ICO image loader. This flaw allows remote attackers to craft ICO images with a manipulated data_size value that triggers a heap buffer overflow. Exploitation can lead to process crashes or potentially remote code execution.