Skip to main content
VulnerabilityPublished Updated

CVE-2026-111943: delve security update

Affects delveSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-111943· Medium 6.8

Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.26.1-2.el9_8 when convenient.

Data as of 6 Nov 2026, 13:06 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.16.8
Patch
Available – fixed in 1.26.1-2.el9_8
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the AlmaLinux delve package to 1.26.1-2.el9_8.

Affected software

ProductAffectedFixed in
AlmaLinux 9delveAffected
  • <1.26.1-2.el9_8
Fixed in
  • 1.26.1-2.el9_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied promptly. The fixed version is 1.26.1-2.el9_8. Users should upgrade to this version or later to remediate the vulnerability. Refer to the Red Hat advisory RHSA-2026:95518 for detailed update instructions. No additional mitigations are indicated by the vendor advisory.

Description

A security vulnerability (CVE-2026-111943) affecting Delve, a debugger for the Go programming language, involves man-in-the-middle attacks via untrusted intermediate certificates in the crypto/x509 package. This issue has been addressed in Delve version 1.26.1-2.el9_8. The vulnerability could allow attackers to intercept or manipulate communications by exploiting certificate validation flaws. A patch is available and should be applied to affected systems.

References

Community reviews

Loading reviews…