Skip to main content
VulnerabilityPublished

CVE-2026-26007: Important · fence-agents security update

Affects fence-agents-aliyunSource GCVE Database

0
Authoritative record:CVE-2026-26007· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 4.2.1-129.el8_10.25 soon.

Data as of 27 Oct 2026, 00:19 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.2.1-129.el8_10.25
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 4.2.1-129.el8_10.25.

Affected software

ProductAffectedFixed in
AlmaLinux 8fence-agents-aliyunAffected
  • <4.2.1-129.el8_10.25
Fixed in
  • 4.2.1-129.el8_10.25
AlmaLinux 8fence-agents-allAffected
  • <4.2.1-129.el8_10.25
Fixed in
  • 4.2.1-129.el8_10.25
AlmaLinux 8fence-agents-amt-wsAffected
  • <4.2.1-129.el8_10.25
Fixed in
  • 4.2.1-129.el8_10.25
AlmaLinux 8fence-agents-apcAffected
  • <4.2.1-129.el8_10.25
Fixed in
  • 4.2.1-129.el8_10.25
AlmaLinux 8fence-agents-apc-snmpAffected
  • <4.2.1-129.el8_10.25
Fixed in
  • 4.2.1-129.el8_10.25
AlmaLinux 8fence-agents-awsAffected
  • <4.2.1-129.el8_10.25
Fixed in
  • 4.2.1-129.el8_10.25

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied. The fixed version is 4.2.1-129.el8_10.25. Users should update fence-agents to this version or later to remediate the vulnerability. Refer to the Red Hat advisory RHSA-2026:12176 for detailed update instructions.

Description

The fence-agents package includes scripts for remote power management in cluster environments, enabling forced restart and removal of failed or unreachable nodes. A security update addresses multiple vulnerabilities, including CVE-2026-26007, which is a cryptography subgroup attack due to missing subgroup validation for SECT curves. Additional fixes address vulnerabilities in pyjwt and pyasn1 libraries. The update is rated as Important by Red Hat and fixes are available in version 4.2.1-129.el8_10.25.

References

Community reviews

Loading reviews…