Skip to main content
VulnerabilityPublished Updated

CVE-2026-31678: kernel security, bug fix, and enhancement update

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-31678· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 5.14.0-687.59.1.el9_8 soon.

Data as of 5 Nov 2026, 01:58 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Linux)CVSS 3.17.8
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.14.0-687.59.1.el9_8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the AlmaLinux to 5.14.0-687.59.1.el9_8.

Affected software

ProductAffectedFixed in
AlmaLinux 9kernelAffected
  • <5.14.0-687.59.1.el9_8
Fixed in
  • 5.14.0-687.59.1.el9_8
AlmaLinux 9kernel-64kAffected
  • <5.14.0-687.59.1.el9_8
Fixed in
  • 5.14.0-687.59.1.el9_8
AlmaLinux 9kernel-64k-coreAffected
  • <5.14.0-687.59.1.el9_8
Fixed in
  • 5.14.0-687.59.1.el9_8
AlmaLinux 9kernel-64k-debugAffected
  • <5.14.0-687.59.1.el9_8
Fixed in
  • 5.14.0-687.59.1.el9_8
AlmaLinux 9kernel-64k-debug-coreAffected
  • <5.14.0-687.59.1.el9_8
Fixed in
  • 5.14.0-687.59.1.el9_8
AlmaLinux 9kernel-64k-debug-develAffected
  • <5.14.0-687.59.1.el9_8
Fixed in
  • 5.14.0-687.59.1.el9_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available that addresses these vulnerabilities in the Linux kernel. Systems running affected versions prior to 5.14.0-687.59.1.el9_8 should apply the update as provided by Red Hat and reboot the system to ensure the fixes take effect. Red Hat recommends treating all kernel errata as security-relevant and promptly applying updates.

Description

Multiple security vulnerabilities affecting the Linux kernel have been addressed in an important update for Red Hat Enterprise Linux 9. These include fixes for use-after-free, memory corruption, denial of service, and information leak issues across various kernel subsystems such as openvswitch, xfrm, USB serial, bridge multicast, TCP, Bluetooth, IPv4, SMB client, perf, and others. The update also includes bug fixes and enhancements. Affected systems must apply the update and reboot to mitigate these issues.

References

Community reviews

Loading reviews…