Skip to main content
VulnerabilityPublished Updated

CVE-2026-94286: libXtst security update

Affects libXtstSource GCVE Database

0
Compare
Authoritative record:CVE-2026-94286· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 1.2.3-16.el9_8.1 soon.

Data as of 30 Oct 2026, 02:00 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.3-16.el9_8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 1.2.3-16.el9_8.1.

Affected software

ProductAffectedFixed in
AlmaLinux 9libXtstAffected
  • <1.2.3-16.el9_8.1
Fixed in
  • 1.2.3-16.el9_8.1
AlmaLinux 9libXtst-develAffected
  • <1.2.3-16.el9_8.1
Fixed in
  • 1.2.3-16.el9_8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in libXtst version 1.2.3-16.el9_8.1. Users of affected Red Hat Enterprise Linux 9 variants should apply this update promptly. Refer to Red Hat advisory RHSA-2026:91223 and the linked article https://access.redhat.com/articles/11258 for detailed update instructions. No additional mitigation is required beyond applying the official patch.

Description

A denial of service vulnerability exists in the X.Org X11 libXtst runtime library due to an out-of-bounds read in the RECORD reply parser. This issue is tracked as CVE-2026-94286. The vulnerability affects versions of libXtst prior to 1.2.3-16.el9_8.1. Red Hat has issued an important security update to address this flaw in Red Hat Enterprise Linux 9 and related variants.

References

Community reviews

Loading reviews…