Skip to main content
VulnerabilityPublished

CVE-2026-109088: libXtst security update

Affects libXtstSource GCVE Database

0
Compare
Authoritative record:CVE-2026-109088· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.2.4-4.oe2203sp4 when convenient.

Data as of 29 Oct 2026, 11:03 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (suse)CVSS 3.16.5
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.4-4.oe2203sp4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libXtst to 1.2.4-4.oe2203sp4.

Affected software

ProductAffectedFixed in
openEuler 22.03-LTS-SP4libXtstpkg:rpm/openEuler/libXtst&distro=openEuler-22.03-LTS-SP4Other threatsAffected
  • <1.2.4-4.oe2203sp4
Fixed in
  • 1.2.4-4.oe2203sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security fix is available in libXtst version 1.2.4-4.oe2203sp4. Users and administrators should update to this fixed version to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

Multiple security issues were identified in the X.Org X11 libXtst runtime library, leading to the release of security fixes under CVE-2026-109088. The vulnerability affects versions prior to 1.2.4-4.oe2203sp4. The issues do not impact confidentiality or integrity but can cause availability disruption. A patch is available in version 1.2.4-4.oe2203sp4.

References

Community reviews

Loading reviews…