CVE-2026-94286: libXtst security update
Affects libXtstSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 1.2.3-8.el8_10 soon.
Data as of 28 Oct 2026, 18:47 UTC
- Patch
- Available – fixed in 1.2.3-8.el8_10
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the AlmaLinux to 1.2.3-8.el8_10.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 8libXtst | Affected
| Fixed in
|
| AlmaLinux 8libXtst-devel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing this vulnerability is available in libXtst version 1.2.3-8.el8_10 for Red Hat Enterprise Linux 8. Users should apply this update promptly to remediate the issue. Refer to the Red Hat advisory RHSA-2026:91294 and the update instructions at https://access.redhat.com/articles/11258 for detailed guidance.
Description
A denial of service vulnerability exists in the X.Org X11 libXtst runtime library due to an out-of-bounds read in the RECORD reply parser. This issue is identified as CVE-2026-94286. The vulnerability affects libXtst versions prior to 1.2.3-8.el8_10. Red Hat has released an important security update to address this issue in Red Hat Enterprise Linux 8. No known exploits in the wild have been reported.