Skip to main content
VulnerabilityPublished

CVE-2026-96442: emacs security update

Affects emacsSource GCVE Database

0
Authoritative record:CVE-2026-96442· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 1:26.1-15.el8_10.4 soon.

Data as of 27 Oct 2026, 22:00 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1:26.1-15.el8_10.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 1:26.1-15.el8_10.4.

Affected software

ProductAffectedFixed in
AlmaLinux 8emacsAffected
  • <1:26.1-15.el8_10.4
Fixed in
  • 1:26.1-15.el8_10.4
AlmaLinux 8emacs-commonAffected
  • <1:26.1-15.el8_10.4
Fixed in
  • 1:26.1-15.el8_10.4
AlmaLinux 8emacs-filesystemAffected
  • <1:26.1-15.el8_10.4
Fixed in
  • 1:26.1-15.el8_10.4
AlmaLinux 8emacs-lucidAffected
  • <1:26.1-15.el8_10.4
Fixed in
  • 1:26.1-15.el8_10.4
AlmaLinux 8emacs-noxAffected
  • <1:26.1-15.el8_10.4
Fixed in
  • 1:26.1-15.el8_10.4
AlmaLinux 8emacs-terminalAffected
  • <1:26.1-15.el8_10.4
Fixed in
  • 1:26.1-15.el8_10.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied immediately. Red Hat has released fixed packages (version 1:26.1-15.el8_10.4) for Red Hat Enterprise Linux 8. Users should update Emacs to this version or later to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

GNU Emacs contains a security vulnerability in Flymake mode that allows arbitrary code execution. This issue affects versions prior to 1:26.1-15.el8_10.4. A security update has been released by Red Hat to address this vulnerability.

References

Community reviews

Loading reviews…