Skip to main content
VulnerabilityPublished

CVE-2026-95325: webkit2gtk3 security update

Affects webkit2gtk3Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-95325· Critical 9.6

Not known to be exploited · CVSS 9.6 Critical : upgrade to 2.54.2-1.el8_10 as a priority.

Data as of 28 Oct 2026, 18:46 UTC

CVSS 3.1 base score
9.6Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.54.2-1.el8_10
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 2.54.2-1.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8webkit2gtk3Affected
  • <2.54.2-1.el8_10
Fixed in
  • 2.54.2-1.el8_10
AlmaLinux 8webkit2gtk3-develAffected
  • <2.54.2-1.el8_10
Fixed in
  • 2.54.2-1.el8_10
AlmaLinux 8webkit2gtk3-jscAffected
  • <2.54.2-1.el8_10
Fixed in
  • 2.54.2-1.el8_10
AlmaLinux 8webkit2gtk3-jsc-develAffected
  • <2.54.2-1.el8_10
Fixed in
  • 2.54.2-1.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied to affected systems. The fixed version is 2.54.2-1.el8_10. Users of Red Hat Enterprise Linux 8 should update their webkit2gtk3 package to this version or later to remediate these vulnerabilities. Refer to the Red Hat advisory for detailed update instructions.

Description

WebKitGTK, the GTK port of the WebKit rendering engine, has multiple security vulnerabilities in its ANGLE component, including use-after-free, out-of-bounds read/write, buffer overflow, type confusion, and uninitialized resource issues. These vulnerabilities affect versions of webkit2gtk3 prior to 2.54.2-1.el8_10. A security update fixing these issues is available for Red Hat Enterprise Linux 8.

References

Community reviews

Loading reviews…