CVE-2026-94286: libXtst security update
Affects libXtstSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 1.2.4-8.el10_2.1 soon.
Data as of 28 Oct 2026, 15:46 UTC
- Patch
- Available – fixed in 1.2.4-8.el10_2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the AlmaLinux to 1.2.4-8.el10_2.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 10libXtst | Affected
| Fixed in
|
| AlmaLinux 10libXtst-devel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing this vulnerability is available in libXtst version 1.2.4-8.el10_2.1. Users of affected Red Hat Enterprise Linux 10 variants should apply the update as provided by Red Hat's advisory RHSA-2026:91612. No additional mitigation steps are required beyond applying the official patch.
Description
A denial of service vulnerability exists in the X.Org X11 libXtst runtime library due to an out-of-bounds read in the RECORD reply parser. This flaw, tracked as CVE-2026-94286, affects libXtst versions prior to 1.2.4-8.el10_2.1. The issue has been addressed in the fixed version 1.2.4-8.el10_2.1, and an update is available from Red Hat for multiple Red Hat Enterprise Linux 10 variants.