Skip to main content
VulnerabilityPublished Updated

CVE-2026-88806: libX11 security update

Affects libX11Source GCVE Database

0
Authoritative record:CVE-2026-88806· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.10-1.el10_2.1 soon.

Data as of 28 Oct 2026, 17:11 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.10-1.el10_2.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 1.8.10-1.el10_2.1.

Affected software

ProductAffectedFixed in
AlmaLinux 10libX11Affected
  • <1.8.10-1.el10_2.1
Fixed in
  • 1.8.10-1.el10_2.1
AlmaLinux 10libX11-commonAffected
  • <1.8.10-1.el10_2.1
Fixed in
  • 1.8.10-1.el10_2.1
AlmaLinux 10libX11-develAffected
  • <1.8.10-1.el10_2.1
Fixed in
  • 1.8.10-1.el10_2.1
AlmaLinux 10libX11-xcbAffected
  • <1.8.10-1.el10_2.1
Fixed in
  • 1.8.10-1.el10_2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in libX11 version 1.8.10-1.el10_2.1. Users of affected Red Hat Enterprise Linux 10.2 Extended Update Support versions should apply this update promptly. Refer to the Red Hat advisory and article https://access.redhat.com/articles/11258 for detailed update instructions.

Description

A heap-based buffer overflow vulnerability exists in the libX11 library, which is the core X11 protocol client library. This flaw can be triggered by a malicious X server. An important security update addressing this issue is available for affected Red Hat Enterprise Linux 10.2 Extended Update Support versions.

References

Community reviews

Loading reviews…