CVE-2025-55247: Important · .NET 9.0 security update
Affects aspnetcore-runtime-9.0Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.3 High · fixed in 9.0.10-1.el8_10 : patch aspnetcore-runtime-9.0 soon.
Data as of 29 Oct 2026, 23:43 UTC
- Patch
- Available – fixed in 9.0.10-1.el8_10, 9.0.111-1.el8_10
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:CExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the AlmaLinux to 9.0.10-1.el8_10 (aspnetcore-runtime-9.0 package, aspnetcore-runtime-dbg-9.0 package, aspnetcore-targeting-pack-9.0 package, dotnet-apphost-pack-9.0 package, dotnet-host package, dotnet-hostfxr-9.0 package, dotnet-runtime-9.0 package, dotnet-runtime-dbg-9.0 package, dotnet-targeting-pack-9.0 package) or 9.0.111-1.el8_10 (dotnet package, dotnet-sdk-9.0 package, dotnet-sdk-9.0-source-built-artifacts package, dotnet-sdk-aot-9.0 package, dotnet-sdk-dbg-9.0 package, dotnet-templates-9.0 package, netstandard-targeting-pack-2.1 package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 8aspnetcore-runtime-9.0 | Affected
| Fixed in
|
| AlmaLinux 8aspnetcore-runtime-dbg-9.0 | Affected
| Fixed in
|
| AlmaLinux 8aspnetcore-targeting-pack-9.0 | Affected
| Fixed in
|
| AlmaLinux 8dotnet | Affected
| Fixed in
|
| AlmaLinux 8dotnet-apphost-pack-9.0 | Affected
| Fixed in
|
| AlmaLinux 8dotnet-host | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official updates to .NET SDK 9.0.111 and .NET Runtime 9.0.10 as provided by Red Hat for affected Red Hat Enterprise Linux 8 and related products. These updates resolve CVE-2025-55247 and associated vulnerabilities. No additional mitigation actions are indicated by the vendor advisory.
Description
.NET 9.0 contains a denial of service vulnerability identified as CVE-2025-55247. This issue affects the .NET SDK and Runtime prior to versions 9.0.111 and 9.0.10 respectively. The vulnerability has been addressed in these updated versions. Additional related vulnerabilities include information disclosure and security feature bypass issues, also fixed in the same updates.
References
- access.redhat.com/errata/RHSA-2025:18150 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55247 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55248 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55315 (opens in a new tab)
- bugzilla.redhat.com/2403083 (opens in a new tab)
- bugzilla.redhat.com/2403085 (opens in a new tab)
- bugzilla.redhat.com/2403086 (opens in a new tab)
- errata.almalinux.org/8/ALSA-2025-18150.html (opens in a new tab)