CVE-2025-55248: Important · .NET 9.0 security update
Affects aspnetcore-runtime-9.0Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 4.8 Medium · fixed in 9.0.10-1.el10_0 : update aspnetcore-runtime-9.0 when convenient.
Data as of 29 Oct 2026, 23:42 UTC
- Patch
- Available – fixed in 9.0.10-1.el10_0, 9.0.111-1.el10_0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N/E:U/RL:O/RC:CExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the AlmaLinux to 9.0.10-1.el10_0 (aspnetcore-runtime-9.0 package, aspnetcore-runtime-dbg-9.0 package, aspnetcore-targeting-pack-9.0 package, dotnet-apphost-pack-9.0 package, dotnet-host package, dotnet-hostfxr-9.0 package, dotnet-runtime-9.0 package, dotnet-runtime-dbg-9.0 package, dotnet-targeting-pack-9.0 package) or 9.0.111-1.el10_0 (dotnet-sdk-9.0 package, dotnet-sdk-9.0-source-built-artifacts package, dotnet-sdk-aot-9.0 package, dotnet-sdk-dbg-9.0 package, dotnet-templates-9.0 package, netstandard-targeting-pack-2.1 package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 10aspnetcore-runtime-9.0 | Affected
| Fixed in
|
| AlmaLinux 10aspnetcore-runtime-dbg-9.0 | Affected
| Fixed in
|
| AlmaLinux 10aspnetcore-targeting-pack-9.0 | Affected
| Fixed in
|
| AlmaLinux 10dotnet-apphost-pack-9.0 | Affected
| Fixed in
|
| AlmaLinux 10dotnet-host | Affected
| Fixed in
|
| AlmaLinux 10dotnet-hostfxr-9.0 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official updates provided by Red Hat: upgrade to .NET SDK version 9.0.111 or later and .NET Runtime version 9.0.10 or later. These versions contain fixes for the disclosed vulnerabilities. Follow Red Hat's update instructions as detailed in their advisory (https://access.redhat.com/articles/11258). No additional mitigation actions are indicated by the vendor advisory.
Description
.NET 9.0 contains multiple security vulnerabilities including an information disclosure flaw (CVE-2025-55248), a security feature bypass (CVE-2025-55315), and a denial of service vulnerability (CVE-2025-55247). These issues affect the .NET SDK and Runtime versions prior to 9.0.111 and 9.0.10 respectively. Updated versions addressing these vulnerabilities have been released. The vulnerabilities impact Red Hat Enterprise Linux 10 and related distributions. No known exploits in the wild have been reported at this time.
References
- access.redhat.com/errata/RHSA-2025:18153 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55247 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55248 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55315 (opens in a new tab)
- bugzilla.redhat.com/2403083 (opens in a new tab)
- bugzilla.redhat.com/2403085 (opens in a new tab)
- bugzilla.redhat.com/2403086 (opens in a new tab)
- errata.almalinux.org/10/ALSA-2025-18153.html (opens in a new tab)