CVE-2025-55247: Important · .NET 9.0 security update
Affects aspnetcore-runtime-9.0Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.3 High · fixed in 9.0.10-1.el9_6 : patch aspnetcore-runtime-9.0 soon.
Data as of 29 Oct 2026, 23:43 UTC
- Patch
- Available – fixed in 9.0.10-1.el9_6, 9.0.111-1.el9_6
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:CExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the AlmaLinux to 9.0.10-1.el9_6 (aspnetcore-runtime-9.0 package, aspnetcore-runtime-dbg-9.0 package, aspnetcore-targeting-pack-9.0 package, dotnet-apphost-pack-9.0 package, dotnet-host package, dotnet-hostfxr-9.0 package, dotnet-runtime-9.0 package, dotnet-runtime-dbg-9.0 package, dotnet-targeting-pack-9.0 package) or 9.0.111-1.el9_6 (dotnet-sdk-9.0 package, dotnet-sdk-9.0-source-built-artifacts package, dotnet-sdk-aot-9.0 package, dotnet-sdk-dbg-9.0 package, dotnet-templates-9.0 package, netstandard-targeting-pack-2.1 package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9aspnetcore-runtime-9.0 | Affected
| Fixed in
|
| AlmaLinux 9aspnetcore-runtime-dbg-9.0 | Affected
| Fixed in
|
| AlmaLinux 9aspnetcore-targeting-pack-9.0 | Affected
| Fixed in
|
| AlmaLinux 9dotnet-apphost-pack-9.0 | Affected
| Fixed in
|
| AlmaLinux 9dotnet-host | Affected
| Fixed in
|
| AlmaLinux 9dotnet-hostfxr-9.0 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches provided by the vendor by upgrading to .NET SDK 9.0.111 and .NET Runtime 9.0.10 or later. The vendor advisory from Red Hat provides detailed instructions for updating affected systems. Since patches are available and the vulnerability is fixed in these versions, remediation through patching is the recommended and effective mitigation.
Description
.NET 9.0 contains a denial of service vulnerability identified as CVE-2025-55247. This vulnerability affects the .NET runtime and SDK versions prior to 9.0.10 and 9.0.111 respectively. Updated versions addressing this issue are available. The vulnerability is part of a set including information disclosure and security feature bypass issues. The vendor has rated the security impact as Important and has released patches to remediate the flaw.
References
- access.redhat.com/errata/RHSA-2025:18151 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55247 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55248 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-55315 (opens in a new tab)
- bugzilla.redhat.com/2403083 (opens in a new tab)
- bugzilla.redhat.com/2403085 (opens in a new tab)
- bugzilla.redhat.com/2403086 (opens in a new tab)
- errata.almalinux.org/9/ALSA-2025-18151.html (opens in a new tab)