Skip to main content
VulnerabilityPublished Updated

CVE-2026-68498: Important · pki-deps:10.6 security update

Affects apache-commons-collectionsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-68498· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 3.2.2-10.module_el8.5.0+2577+9e95fe00 : patch apache-commons-collections soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2-10.module_el8.5.0+2577+9e95fe00, 2.6-21.module_el8.5.0+2577+9e95fe00, 3.6-3.module_el8.5.0+2577+9e95fe00 +22
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
AlmaLinux 8apache-commons-collectionsAffected
  • <3.2.2-10.module_el8.5.0+2577+9e95fe00
Fixed in
  • 3.2.2-10.module_el8.5.0+2577+9e95fe00
AlmaLinux 8apache-commons-langAffected
  • <2.6-21.module_el8.5.0+2577+9e95fe00
Fixed in
  • 2.6-21.module_el8.5.0+2577+9e95fe00
AlmaLinux 8apache-commons-netAffected
  • <3.6-3.module_el8.5.0+2577+9e95fe00
Fixed in
  • 3.6-3.module_el8.5.0+2577+9e95fe00
AlmaLinux 8bea-stax-apiAffected
  • <1.2.0-16.module_el8.5.0+2577+9e95fe00
Fixed in
  • 1.2.0-16.module_el8.5.0+2577+9e95fe00
AlmaLinux 8glassfish-fastinfosetAffected
  • <1.2.13-9.module_el8.5.0+2577+9e95fe00
Fixed in
  • 1.2.13-9.module_el8.5.0+2577+9e95fe00
AlmaLinux 8glassfish-jaxb-apiAffected
  • <2.2.12-8.module_el8.5.0+2577+9e95fe00
Fixed in
  • 2.2.12-8.module_el8.5.0+2577+9e95fe00

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied to affected Red Hat Enterprise Linux 8 systems using the pki-deps:10.6 module. Fixed versions include 3.2.2-10.module_el8.5.0+2577+9e95fe00 and later for jackson-core and related packages. Administrators should follow Red Hat's official guidance to update to these fixed versions to remediate the vulnerabilities.

Description

This security advisory addresses multiple denial of service vulnerabilities in the Jackson JSON processing libraries used by the Public Key Infrastructure (PKI) Core in Red Hat Certificate System. Specifically, CVE-2026-68498 concerns a denial of service via excessively long JSON property names in jackson-core. The update fixes these issues by patching the affected Jackson components. The vulnerabilities could allow an attacker to cause service disruption by exploiting unbounded resource consumption during JSON processing.

References

Community reviews

Loading reviews…