CVE-2026-13595: Important · util-linux security update
Affects libblkidSource GCVE Database
Not known to be exploited · CVSS 6.8 Medium : upgrade to 2.40.2-18.el10_2.20 when convenient.
Data as of 2 Nov 2026, 13:28 UTC
Thin evidence
One scorer or none| CNA (redhat) | CVSS 3.1 | 6.8 |
|---|
- Patch
- Available – fixed in 2.40.2-18.el10_2.20
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade the AlmaLinux to 2.40.2-18.el10_2.20.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 10libblkid | Affected
| Fixed in
|
| AlmaLinux 10libblkid-devel | Affected
| Fixed in
|
| AlmaLinux 10libfdisk | Affected
| Fixed in
|
| AlmaLinux 10libfdisk-devel | Affected
| Fixed in
|
| AlmaLinux 10libmount | Affected
| Fixed in
|
| AlmaLinux 10libmount-devel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 2.40.2-18.el10_2.20 of util-linux is available and should be applied to affected Red Hat Enterprise Linux 10 systems. Administrators should follow the update instructions provided in the Red Hat advisory RHSA-2026:93461 to remediate this vulnerability. No additional mitigation steps are indicated beyond applying the official patch.
Description
A heap use-after-free vulnerability (CVE-2026-13595) exists in the libblkid component of util-linux, a package containing essential low-level Linux system utilities. This flaw affects versions of util-linux prior to 2.40.2-18.el10_2.20. The issue has been addressed in the fixed version 2.40.2-18.el10_2.20. The vulnerability is part of a broader set of security fixes for util-linux released by Red Hat, rated with an Important security impact.
References
- access.redhat.com/errata/RHSA-2026:93461 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-13595 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-27456 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-53612 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-53613 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-53614 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-53615 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-76642 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-78408 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-78410 (opens in a new tab)
- bugzilla.redhat.com/2454956 (opens in a new tab)
- bugzilla.redhat.com/2494101 (opens in a new tab)
- bugzilla.redhat.com/2519646 (opens in a new tab)
- bugzilla.redhat.com/2519647 (opens in a new tab)
- bugzilla.redhat.com/2519648 (opens in a new tab)
- bugzilla.redhat.com/2521999 (opens in a new tab)
- bugzilla.redhat.com/2522497 (opens in a new tab)
- bugzilla.redhat.com/2522684 (opens in a new tab)
- bugzilla.redhat.com/2552551 (opens in a new tab)
- errata.almalinux.org/10/ALSA-2026-93461.html (opens in a new tab)