Skip to main content
VulnerabilityPublished

CVE-2026-100252: Apache ZooKeeper · Improper Authorization Vulnerability

Affects zookeeperSource GCVE Database

0
Compare
Authoritative record:CVE-2026-100252· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 3.9.7 or 3.8.8 soon.

Data as of 4 Nov 2026, 15:17 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.08.6
Patch
Available – fixed in 3.9.7, 3.8.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.zookeeper/zookeeper to 3.9.7 or 3.8.8.

Affected software

ProductAffectedFixed in
Mavenorg.apache.zookeeper/zookeeperpkg:maven/org.apache.zookeeper/zookeeperOther threatsAffected
  • <3.8.8
  • <3.9.7
Fixed in
  • 3.8.8
  • 3.9.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache ZooKeeper versions 3.8.8 or 3.9.7, where this improper authorization vulnerability is fixed. No other mitigations are specified in the advisory.

Description

CVE-2026-100252 is an improper authorization vulnerability in Apache ZooKeeper when SASL authentication is enabled. The server incorrectly grants any authorization identity requested by a client without verifying it against the authenticated principal. If the principal is not covered by the auth_to_local rules, the client can impersonate any SASL identity, including superuser accounts, gaining unauthorized access. The issue is fixed in Apache ZooKeeper versions 3.8.8 and 3.9.7.

References

Community reviews

Loading reviews…