Checkmk <2.5.0p18, <2.4.0p39, <2.3.0p52 · Improper Certificate Validation
Source GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 2.5.0p18 : patch Checkmk soon.
Data as of 29 Oct 2026, 14:41 UTC
Thin evidence
One scorer or none| CNA (Checkmk) | CVSS 4.0 | 7.1 |
|---|
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.0p18, 2.4.0p39, 2.3.0p52
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Checkmk and checkmk/checkmk to 2.5.0p18, 2.4.0p39 or 2.3.0p52.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Checkmk GmbHCheckmk | Affected
| Fixed in
|
GitHubcheckmk/checkmkpkg:github/checkmk/checkmkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider mitigating risk by restricting network access to trusted sources and monitoring for suspicious certificate activity. Avoid using affected versions in untrusted networks if possible.
Description
Checkmk versions prior to 2.5.0p18, 2.4.0p39, 2.3.0p52, and version 2.2.0 (EOL) have improper certificate validation due to inclusion of a root CA that trusts eMudhra (emSign) intermediate certificates with publicly known private keys. This flaw arises from the bundled Certificate Authority stores using "certifi" and "webpki-roots". The vulnerability could allow attackers to exploit the trust in these compromised intermediate certificates.